Configuring Tvheadend

Added by Arend van der Boom over 4 years ago

Hi,

First of all, please let me know if this is the correct forum for my question :)

I have just started with tvheadend on my Ubuntu 12.04 32bits with Tvheadend 3.0. The hardware I use is an USB 2.0 Anysee E30C Plus with smartcard option. After booting Ubuntu the unit is detected as 'ID 1c73:861f AMT Anysee E30 USB 2.0 DVB-T Reciever' be means of lsusb. Although it says DVB-T it is a DVB-C unit.

After logging on into Tvheadend, the adapter is visible under 'TV Adapters' as a 'Philips TDA10023 DVB-C' After entering the network ID for Caiway, my provider, I add a mux and services will become visible under 'Services'. The strange thing is that the number of services is only 14, while there are much more services. (When using the card on Windows I count a 100+ services) The number of services beside, where to go from here ? My thought was to fill the channels but when I check 'General' it still says 'Muxes awaiting initial scan: 1'. My guess is that this needs to be 0 before I can continue to channels.

LS because during testing I removed and added the multiplexes more than once, for some reason the quality of the added mux rolls back from 100% to 0% after adding a mux.

Is it correct that the 'awaiting initial scan' must be 0 ? Is there a way to force a scan, other than restarting tvheadend ?

Kind Regards
Moob


Replies (7)

RE: Configuring Tvheadend - Added by Alex . over 4 years ago

Hi Arend,

After logging on into Tvheadend, the adapter is visible under 'TV Adapters' as a 'Philips TDA10023 DVB-C' After entering the network ID for Caiway, my provider, I add a mux and services will become visible under 'Services'. The strange thing is that the number of services is only 14, while there are much more services. (When using the card on Windows I count a 100+ services) The number of services beside, where to go from here ? My thought was to fill the channels

but when I check 'General' it still says 'Muxes awaiting initial scan: 1'. My guess is that this needs to be 0 before I can continue to channels.
Is it correct that the 'awaiting initial scan' must be 0 ?

Indeed, you should let all the scans finish first.

Is there a way to force a scan, other than restarting tvheadend ?

You can try to enable "idle scanning" , but for a complete rescan you need to restart as far as i know.

LS because during testing I removed and added the multiplexes more than once, for some reason the quality of the added mux rolls back from 100% to 0% after adding a mux.

This seems to be a common issue ( at least it was some time ago). Somehow the monitoring resulted in reduced signal quality, which resulted in not-working muxes ( although the actual signal is not that bad...)
Disable "monitor signal quality", then rescan. ( maybe even remove all muxes and add them all again).
After this, restart tvheadend and look if all channels are now scanned appropriately.

Hope this helps,

Alex.

RE: Configuring Tvheadend - Added by Arend van der Boom over 4 years ago

Hi Alex,

Thanks for your answers.

I have enabled 'idle scanning' and for the 4 frequencies entered I now see a MuxId by 2 off them. The services from those muxes are now added to the channels. It seems a muxid is necessary, without it services are not found and therefore can not be used. Still, I only see far less channels than when I look via Windows. -- I already checked with w_scan and scan and there also a small number of channels get detected. It seems some sort of driver issue, not tvheadend as far as I can see. Please correct me if I am wrong :)

Playing the found channels did not worked. I got an 401 HTTP error. It looks like bug #856 is still in version 3.0 while solved in version 2.13. Don't know if I have to update the bug report though.
As a work-around I have created a new user. When I logon as that user via http://user:[email protected]:9981 I am able to play channels and watch tv. It seems that for some reason the super user account created during the initial setup cannot be used to view tv.

The other thing I ran into was that when I created a user in tvheadend via Firefox 15 on Ubuntu 12.04 I got a 'transaction aborted' error and changes were not saved until I restarted tvheadend. -- This was with user rights on '/usr/share/tvheadend' changed to full access for user 'hts'-- When I performed the same via Firefox 15 on Ubuntu 10.04 the changes where directly saved without any error.

To logon with 2 different users, from 2 different PCs', also seemed not possible. Is that correct ?

Kind regards
Moob

RE: Configuring Tvheadend - Added by Alex . over 4 years ago

Arend van der Boom wrote:

Hi Alex,Thanks for your answers.
I have enabled 'idle scanning' and for the 4 frequencies entered I now see a MuxId by 2 off them. The services from those muxes are now added to the >channels. It seems a muxid is necessary, without it services are not found and therefore can not be used. Still, I only see far less channels than when >I look via Windows. -- I already checked with w_scan and scan and there also a small number of channels get detected. It seems some sort of driver >issue, not tvheadend as far as I can see. Please correct me if I am wrong :)

Indeed, if w_scan gives the same results as tvheadend, it is not a tvheadend problem but a more generic issue.

One thing: I did notice that some providers use a different way of sending information about muxes (specifically Ziggo, which I use, does this to confuse users and to avoid people using their own hardware, but maybe also CaiWay uses a similar system).
Information is distributed on different muxes than the mux itself . So, it would probably help to add more (all?) muxes of CaiWay.
Did you look at this : http://www.digitalekabeltelevisie.nl/techniek/netwerktabel.shtml
I would recommend to add at least the muxes relevant to your area.

RE: Configuring Tvheadend - Added by Arend van der Boom over 4 years ago

Hi Alex,

I have tried scanning all Caiway frequencies but also finding only a few services here. Don't know if w_scan is able to scan on network ID though and then find the services. I am guessing it must be something with the anysee driver as the windows software does find all the services Caiway provides.

Thanks again for your help.

Kind regards
Moob

RE: Configuring Tvheadend - Added by Alex . over 4 years ago

I have tried scanning all Caiway frequencies but also finding only a few services here. Don't know if w_scan is able to scan on network ID though and then find the services. I am guessing it must be something with the anysee driver as the windows software does find all the services Caiway provides.

Might be,

One thing might be worth trying: I found another link with similar information: http://wiki.mythtv.nl/index.php/Zenders
It appears Caiway apparently uses a different symbolrate (6900000 vs 6875000) then the other providers

Maybe try adding the mux by hand ?
It might help, since the default settings in tvheadend for your region might not be correct ( share/tvheadend/data/dvb-scan/dvb-c/nl-REKAM-CAIW_Gouda ) looks different than the parameters on the websites).

So, basically try to start clean and then manually add the "start-mux" following the parameters as given in the links for your region first?

Alex.

RE: Configuring Tvheadend - Added by Hein Rigolo over 4 years ago

what details do you enter when you setup your TV for caiw? You could probably use the same details for your initial mux in tvheadend also.

have a look at the last page of this pdf from caiw;
http://www.caiway.nl/site/documents/4629/3%20vouw%20--harmonica.pdf

the symbol rate depends on which network you are connected to.
Krimpen aan den IJssel (2222)
Albrandswaard (2000)

these are 6875 .. the rest 6900

Hein

RE: Configuring Tvheadend - Added by Arend van der Boom about 4 years ago

So, its been a while, time for an update.

Started again to get the Anysee E30 C Plus working with Tvheadend. After some further searching I found a reference on a maillist about updating the V4L-DVB drivers. This had to do with the hardware ID of the anysee unit, which in the newest units is 15.

I followed the guidlines on http://linuxtv.org/wiki/index.php/How_to_Obtain,_Build_and_Install_V4L-DVB_Device_Drivers to update the V4L-DVB drivers. After compiling and a restart of the computer the command 'w_scan -cNL -fc >> channels.conf' found a lot more services than 14 services before the update. Via 'xine -c ./channels.conf' I was now able to watch all TV channels.

Next I updated TVHeadend to version 3.2.18. Although there where muxes present for some reason tvhead did not found more. So I removed all multiplexes and added them back by hand. After mapping the dvb services to channels I was able to watch TV with Tvheadend.

Tvheadend is working :)

Provider Caiway region 2249
Ubuntu 12.04 32bits

Is it possible to add the muxes into some file so it is visible at 'Add DVB Network by location...' ?

Regards
Moob

(1-7/7)