Sat>ip not connecting to tvheadend mistery

Added by Paul Brown 7 months ago

Hello, this is my first post and hopefully an expert can solve something which should work. Using Ubuntu 14.04 as my os.

I don´t see the install of sat>ip being difficult but damn when you place Http://127.0.0.1:9981 into your web browser there should be that welcome interface to greet you. All i get is that annoying unable to connect screen every time. :(

Before you guys start telling me to google or do the install at said link - yes i have followed the tutorials to the bone , but something is definitely wrong.

Can i just go through what i did and see if the error is there :
-----------------------------------------------------

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
sudo apt-get install curl
curl http://apt.tvheadend.org/repo.gpg.key | sudo apt-key add -
sudo apt-add-repository -r http://apt.tvheadend.org/stable
sudo apt-add-repository http://apt.tvheadend.org/unstable
sudo apt-get update
sudo apt-get install tvheadend


Administrator: root
password: bm2lts

Call tvheadend with http://local host ip : 9981

Tvheadend is on my pc so using my local ip http://127.0.0.1:9981

Never asked me for the pw because i always get connect failed.

I also opened port 9981 on my router.

At the moment i am using vdr to view tv/sat via 3 sat tuners on a seperate board to my main board.

I stop the vdr with :

sudo killall -g vdr

Before typing http://127.0.0.1:9981 into browser.

That´s my install but nothing works ......:(

Please help and thanks .


Replies (46)

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello, this is my first post and hopefully an expert can solve something which should work. Using Ubuntu 14.04 as my os.

I don´t see the install of sat>ip being difficult but damn when you place Http://127.0.0.1:9981 into your web browser there should be that welcome interface to greet you. All i get is that annoying unable to connect screen every time. :(

Before you guys start telling me to google or do the install at said link - yes i have followed the tutorials to the bone , but something is definitely wrong.

Can i just go through what i did and see if the error is there :
-----------------------------------------------------

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
sudo apt-get install curl
curl http://apt.tvheadend.org/repo.gpg.key | sudo apt-key add -
sudo apt-add-repository -r http://apt.tvheadend.org/stable
sudo apt-add-repository http://apt.tvheadend.org/unstable
sudo apt-get update
sudo apt-get install tvheadend


Administrator: root
password: bm2lts

Call tvheadend with http://local host ip : 9981

Tvheadend is on my pc so using my local ip http://127.0.0.1:9981

Never asked me for the pw because i always get connect failed.

I also opened port 9981 on my router.

At the moment i am using vdr to view tv/sat via 3 sat tuners on a seperate board to my main board.

I stop the vdr with :

sudo killall -g vdr

Before typing http://127.0.0.1:9981 into browser.

That´s my install but nothing works ......:(

Please help and thanks .

Firstly, that repo is the old one, I'm not sure how updated it is but the bintray repo should have the latest builds. See AptRepository.

Once you've installed the desired version, run..

tvheadend -v

from any user to confirm it's installed, then run..

ps -ef

to see if it's running, It doesn't matter if vdr is running or not at this point as that shouldn't stop tvheadend from starting. If it's not running try..

sudo service tvheadend start

If it still isn't running check the syslog for details, so..

sudo cat /var/log/syslog | grep tvheadend | less

That should give you some clues as to why it's not starting.

If you're still stuck paste the log lines here :).

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

I ran tvheadend -v

[email protected]:/media/hd/home/reel$ tvheadend -v
tvheadend: version 4.1-2405~geb495a0~trusty
[email protected]:/media/hd/home/reel$

ps -ef but no tvheadend and finally

sudo service tvheadend start

[email protected]:/media/hd/home/reel$ sudo service tvheadend start
[sudo] password for reel:
tvheadend: unrecognized service

I ran the sudo cat /var/log/syslog | grep tvheadend | less command but a very strange readout here :

!file:///home/reel/Desktop/Screenshot%20-%2001092017%20-%2012:13:02%20AM.png
!

Many thanks.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

Here´s a print of :

tvheadend in console -

[email protected]:/media/hd/home/reel$ tvheadend
2017-01-09 11:13:05.518 [   INFO] main: Log started
2017-01-09 11:13:05.523 [   INFO] http: Starting HTTP server 0.0.0.0:9981
2017-01-09 11:13:05.524 [   INFO] htsp: Starting HTSP server 0.0.0.0:9982
2017-01-09 11:13:05.524 [  ERROR] satips: use --satip_bindaddr parameter to select the local IP for SAT>IP
2017-01-09 11:13:05.524 [  ERROR] satips: using Google lookup (might block the task until timeout)
2017-01-09 11:13:05.837 [   INFO] config: loaded
2017-01-09 11:13:05.840 [   INFO] config: scanfile (re)initialization with path <none>
2017-01-09 11:13:05.860 [   INFO] bouquet: new bouquet 'Canal Digitaal SD'
2017-01-09 11:13:05.860 [   INFO] bouquet: new bouquet 'Canal Digitaal HD'
2017-01-09 11:13:05.860 [   INFO] bouquet: new bouquet 'TV Vlaanderen SD'
2017-01-09 11:13:05.860 [   INFO] bouquet: new bouquet 'TV Vlaanderen HD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'TéléSAT SD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'TéléSAT HD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'AustriaSat Astra1'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'Canal Digitaal HD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'TV Vlaanderen HD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'TéléSAT HD'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'AustriaSat Astra3'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'Skylink: Czech Republic'
2017-01-09 11:13:05.861 [   INFO] bouquet: new bouquet 'Skylink: Slovak Republic'
2017-01-09 11:13:05.863 [   INFO] dvr: Creating new configuration ''
2017-01-09 11:13:05.863 [WARNING] dvr: Output directory for video recording is not yet configured for DVR configuration "". Defaulting to to "/home/reel/Videos". This can be changed from the web user interface.
2017-01-09 11:13:05.864 [  ERROR] access: No access entries loaded
2017-01-09 11:13:05.864 [   INFO] csa: Using SSE2 128bit parallel descrambling
2017-01-09 11:13:05.865 [   INFO] descrambler: adding CAID 2600 as constant crypto-word (BISS)
2017-01-09 11:13:05.866 [   INFO] epggrab: module eit created
2017-01-09 11:13:05.866 [   INFO] epggrab: module uk_freesat created
2017-01-09 11:13:05.866 [   INFO] epggrab: module uk_freeview created
2017-01-09 11:13:05.867 [   INFO] epggrab: module viasat_baltic created
2017-01-09 11:13:05.867 [   INFO] epggrab: module Bulsatcom_39E created
2017-01-09 11:13:05.867 [   INFO] epggrab: module psip created
2017-01-09 11:13:05.885 [   INFO] epggrab: module opentv-skyit created
2017-01-09 11:13:05.888 [   INFO] epggrab: module opentv-ausat created
2017-01-09 11:13:05.891 [   INFO] epggrab: module opentv-skyuk created
2017-01-09 11:13:05.893 [   INFO] epggrab: module opentv-skynz created
2017-01-09 11:13:05.902 [   INFO] epggrab: module pyepg created
2017-01-09 11:13:05.902 [   INFO] epggrab: module xmltv created
2017-01-09 11:13:05.915 [ NOTICE] START: HTS Tvheadend version 4.1-2405~geb495a0~trusty started, running as PID:31446 UID:1000 GID:1000, CWD:/media/hd/home/reel CNF:/media/hd/home/reel/.hts/tvheadend
2017-01-09 11:13:06.861 [   INFO] scanfile: DVB-S - loaded 1 regions with 112 networks
2017-01-09 11:13:06.861 [   INFO] scanfile: DVB-T - loaded 43 regions with 1106 networks
2017-01-09 11:13:06.861 [   INFO] scanfile: DVB-C - loaded 17 regions with 56 networks
2017-01-09 11:13:06.861 [   INFO] scanfile: ATSC-T - loaded 2 regions with 9 networks
2017-01-09 11:13:06.862 [   INFO] scanfile: ATSC-C - loaded 1 regions with 5 networks
2017-01-09 11:13:06.862 [   INFO] scanfile: ISDB-T - loaded 2 regions with 1297 networks
2017-01-09 11:13:06.888 [   INFO] avahi: Service 'Tvheadend' successfully established.

I am confused , where is the output i should be viewing from my monitor ?

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

I ran tvheadend -v

[email protected]:/media/hd/home/reel$ tvheadend -v
tvheadend: version 4.1-2405~geb495a0~trusty
[email protected]:/media/hd/home/reel$

ps -ef but no tvheadend and finally

sudo service tvheadend start

[email protected]:/media/hd/home/reel$ sudo service tvheadend start
[sudo] password for reel:
tvheadend: unrecognized service

If you installed via a deb package that should've worked, if you manually installed, this is to be expected. However, try

sudo systemctl disable tvheadend
sudo systemctl enable tvheadend

And try starting it again.

I ran the sudo cat /var/log/syslog | grep tvheadend | less command but a very strange readout here :

That blank result is because sudo is asking for your password, you needed to run something with sudo first to unlock it so it doesn't prompt.

sudo whoami
should do it. Once you've entered your password run the command again.

!file:///home/reel/Desktop/Screenshot%20-%2001092017%20-%2012:13:02%20AM.png
!

Many thanks.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

[email protected]:/media/hd/home/reel$ sudo systemctl disable tvheadend
[sudo] password for reel: 
sudo: systemctl: command not found
[email protected]:/media/hd/home/reel$
That blank result is because sudo is asking for your password, you needed to run something with sudo first to unlock it so it doesn't prompt. 

OK, but that blank screen is the very result of entering :

sudo cat /var/log/syslog | grep tvheadend | less

Have not been prompted for a password to date , however, if that blank screen is the prompt for me to enter a pw , it is futile because it will not let me type anything.

I am sorry about all this and this could be my lack of linux know how.

I am stuck. :(

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

[...]

[...]

OK, but that blank screen is the very result of entering :

[...]

You need run "sudo whoami" first before running that command.

Have not been prompted for a password to date , however, if that blank screen is the prompt for me to enter a pw , it is futile because it will not let me type anything.

No, it isn't a prompt to ask for a password, it's blank because the command requires a password & won't output anything to grep/less until it gets one. running the command above will unlock the system so that you can use sudo without being prompted for a password (for a while).

I am sorry about all this and this could be my lack of linux know how.

You'd be better off joining the IRC channel for faster responses :).

I am stuck. :(

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

I ran cammand <whoami> in console and the output was :

< root >

Then ran :

< sudo cat /var/log/syslog | grep tvheadend | less >

the output is the same black screen ?

I tried typing in root but like i said before the console does not let me type anything in that black screen.

I am sorry about this, you are obviously trying to explain something which is obvious to you but is not registering with my logic.

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

I ran cammand <whoami> in console and the output was :

< root >

Then ran :

< sudo cat /var/log/syslog | grep tvheadend | less >

the output is the same black screen ?

I tried typing in root but like i said before the console does not let me type anything in that black screen.

I am sorry about this, you are obviously trying to explain something which is obvious to you but is not registering with my logic.

No need to apologise at all, try just "sudo cat /var/log/syslog" & see if that outputs anything :).

sudo cat /var/log/daemon.log might show info too :).

Seriously come chat on IRC, https://kiwiirc.com/client/chat.freenode.net/?nick=tvhhelp|?#hts :)

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

Yes, the command :

< sudo cat /var/log/syslog >

Printed out basically a run down of my os , components etc.....

Is this good ?

PS : I am on the irc channel now - names DogLeg

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

Yes, the command :

< sudo cat /var/log/syslog >

Printed out basically a run down of my os , components etc.....

Is this good ?

PS : I am on the irc channel now - names DogLeg

I saw you on the IRC channel :)

OK, what does.

sudo cat /var/log/syslog | grep tvheadend

Output?

If it's blank that means tvheadend hasn't logged anything/not started.

Can you say how you installed tvheadend?

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

sudo cat /var/log/syslog | grep tvheadend

This outputs my os password

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

[...]

This outputs my os password

I think you mean it outputs something like this..

[sudo] password for mark:
.

Just enter your password & it should display the output & not your password. The lines should start with tvheadend.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Can you say how you installed tvheadend?<

I installed it manually i.e. exactly the way i put it in first post.

I am confused ..... no, that´s an understatement .

How can i enter my pw if the black screen won´t let me.

Do you mean , open console and enter my os pw ?

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Entered <sudo cat /var/log/syslog | grep tvheadend<

and outputs :

<[sudo] password for reel:<

I enter my pw and outputs :

<[email protected]:/media/hd/home/reel$

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Here´s a screen of the error message when entering http://127.0.0.1:9981

Ok it's blank. that means tvheadend has never been started. do you have the tvheadend start up script in /etc/init.d/?

ls -lah /etc/init.d/

should list the file tvheadend.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

I can´t find a file in etc/init.d called tvheadend and

< ls -lah /etc/init.d/ > doesn´t list tvheadend either.

[email protected]:/media/hd/home/reel$ ls -lah /etc/init.d/
total 976K
drwxr-xr-x   2 root root 4.0K Jan  7 20:04 .
drwxr-xr-x 220 root root  12K Jan  9 20:31 ..
-rwxr-xr-x   1 root root 2.2K Apr  3  2014 acpid
-rwxr-xr-x   1 root root  652 Jul  9  2010 acpi-support
-rwxr-xr-x   1 root root  634 Dec 20  2014 ajaxterm.all
-rwxr-xr-x   1 root root  844 Oct 29  2011 ajenti.all
-rwxr-xr-x   1 root root 2.0K Feb 20  2014 anacron
-rwxr-xr-x   1 root root 9.8K Jan  7  2014 apache2
lrwxrwxrwx   1 root root   21 Jan  2  2015 apparmor -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 4.5K Apr 24  2015 apparmor.dpkg-new
lrwxrwxrwx   1 root root   21 Jan  2  2015 atd -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 2.1K Feb  4  2014 autofs
-rwxr-xr-x   1 root root 2.4K Dec 30  2013 avahi-daemon
-rwxr-xr-x   1 root root 4.4K Jan 12  2014 bftpd-server
-rwxr-xr-x   1 root root 1.3K Mar 30  2014 binfmt-support
-rwxr-xr-x   1 root root 1.8K Feb 17  2010 binfmt-support.dpkg-old
-rwxr-xr-x   1 root root 4.4K Apr 10  2014 bluetooth.all
-rwxr-xr-x   1 root root 2.3K Sep  7  2009 bootlogd
lrwxrwxrwx   1 root root   21 Jan  2  2015 bridge-network-interface -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 2.1K Mar 14  2014 brltty
-rwxr-xr-x   1 root root 9.1K Nov 24  2014 clamav-daemon.all
-rwxr-xr-x   1 root root 8.4K Nov 24  2014 clamav-freshclam.all
-rwxr-xr-x   1 root root 5.6K Jun  5  2011 cnxt-modules
lrwxrwxrwx   1 root root   21 Jan  2  2015 console-setup -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 cron -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 3.2K Apr  3  2014 cups
-rwxr-xr-x   1 root root 2.0K Apr  7  2014 cups-browsed
lrwxrwxrwx   1 root root   21 Jan  2  2015 dbus -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 5.0K Jun  5  2011 decypher
lrwxrwxrwx   1 root root   21 Jan  2  2015 dmesg -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 1.2K Mar  7  2013 dns-clean
-rwxr-xr-x   1 root root 2.3K Feb 19  2014 dropbear
-rwxr-xr-x   1 root root 5.2K Jun  5  2011 dvbloop.all
-rwxr-xr-x   1 root root 1.9K Oct 29  2012 etc-setserial
lrwxrwxrwx   1 root root   21 Jan  2  2015 failsafe-x -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 1.6K Jan 15  2014 fancontrol
-rwxr-xr-x   1 root root 1.6K Feb 15  2010 fancontrol.dpkg-bak
-rwxr-xr-x   1 root root 4.4K Jan  5  2012 fpleds
lrwxrwxrwx   1 root root   21 Jan  2  2015 friendly-recovery -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 5.0K Jan 22  2014 gdm
-rwxr-xr-x   1 root root 2.5K Mar  5  2010 gpm
-rwxr-xr-x   1 root root 1.1K May  8  2014 grub-common
-rwxr-xr-x   1 root root 1.3K Mar 13  2014 halt
-rwxr-xr-x   1 root root 2.9K Nov  6  2008 hddtemp
-rwxr-xr-x   1 root root 3.0K Oct 29  2012 hddtemp.dpkg-dist
lrwxrwxrwx   1 root root   21 Jan  2  2015 hostname -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 kdm -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 3.1K Mar 28  2014 kerneloops
-rwxr-xr-x   1 root root 1.3K Mar 13  2014 killprocs
-rwxr-xr-x   1 root root 2.0K Jan 22  2013 kmod
-rwxr-xr-x   1 root root 1.7K Oct 31  2013 LCDd
-rw-r--r--   1 root root    0 Jul 22  2014 .legacy-bootordering
-rwxr-xr-x   1 root root 3.4K Apr  8  2014 lightdm
-rwxr-xr-x   1 root root 2.5K Apr  6  2010 lighttpd
-rwxr-xr-x   1 root root 2.5K Apr  6  2010 lighttpd.all
-rwxr-xr-x   1 root root 2.9K Jan 28  2014 lighttpd.org
-rwxr-xr-x   1 root root 7.2K Mar 28  2010 lirc
-rwxr-xr-x   1 root root 7.2K Mar 28  2010 lirc.all
-rwxr-xr-x   1 root root 7.9K Mar 16  2014 lirc.new
-rwxr-xr-x   1 root root  869 Jan 15  2014 lm-sensors
-rwxr-xr-x   1 root root  866 Feb 15  2010 lm-sensors.dpkg-old
-rwxr-xr-x   1 root root 5.3K Dec 23  2014 mcli
-rwxr-xr-x   1 root root 5.3K Dec 23  2014 mcli.all
-rwxr-xr-x   1 root root 5.0K Nov 10  2013 mediatomb.all
-rwxr-xr-x   1 root root 1.7K Dec  5  2011 memcached
-rwxr-xr-x   1 root root 4.4K Apr 28  2014 minidlna
lrwxrwxrwx   1 root root   21 Jan 10  2016 minisatip -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 module-init-tools -> /lib/init/upstart-job
-rwxr-xr-x   1 root root  194 Dec 22  2011 mount_prep_local
-rwxr-xr-x   1 root root  684 Jan 27  2014 munin
lrwxrwxrwx   1 root root   21 Jan  2  2015 munin-node -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 5.4K Jul 21  2014 mysql
-rwxr-xr-x   1 root root 5.4K Jul 21  2014 mysql.all
-rwxr-xr-x   1 root root  462 Feb 16  2013 netping
-rwxr-xr-x   1 root root 4.6K Dec 22  2011 netserver_wol
-rwxr-xr-x   1 root root 4.4K Mar 20  2014 networking
-rwxr-xr-x   1 root root 4.8K Jul 18  2014 nfs-kernel-server
-rwxr-xr-x   1 root root 4.8K Jul 18  2014 nfs-kernel-server.all
-rwxr-xr-x   1 root root 4.8K Jul 18  2014 nfs-kernel-server.startme
-rwxr-xr-x   1 root root 1.4K Mar 13  2015 ondemand
-rwxr-xr-x   1 root root  913 Jan  3  2016 oscam-server
-rwxr-xr-x   1 root root 2.4K Mar  7  2010 pcmciautils
-rwxr-xr-x   1 root root 4.3K Feb 17  2014 php5-fpm
lrwxrwxrwx   1 root root   21 Jan  2  2015 plymouth -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 plymouth-log -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 plymouth-splash -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 plymouth-stop -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 portmap -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 portmap-boot -> /lib/init/upstart-job
lrwxrwxrwx   1 root root   21 Jan  2  2015 portmap-wait -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 6.9K Oct  7  2011 postfix
-rwxr-xr-x   1 root root 6.9K Oct  7  2011 postfix.dpkg-dist
-rwxr-xr-x   1 root root 1.1K Oct  7  2011 postgresql-8.4
-rwxr-xr-x   1 root root  561 Jan 22  2013 pppd-dns
-rwxr-xr-x   1 root root 2.2K Mar 27  2010 pulseaudio.all
-rwxr-xr-x   1 root root 2.0K Oct 16  2011 rbc
-rwxr-xr-x   1 root root 2.0K Oct 16  2011 rbc.all
-rwxr-xr-x   1 root root 6.0K Mar 13  2014 rc
-rwxr-xr-x   1 root root  782 Mar 13  2014 rc.local
-rwxr-xr-x   1 root root  117 Mar 13  2014 rcS
-rw-r--r--   1 root root 2.4K Mar 13  2014 README
-rwxr-xr-x   1 root root  639 Mar 13  2014 reboot
-rwxr-xr-x   1 root root 6.1K Jan  2  2015 reelbox-control.all
-rwxr-xr-x   1 root root  674 Sep 10  2010 reel-dyndns.all
-rwxr-xr-x   1 root root  626 Sep 10  2010 reel-umts.all
-rwxr-xr-x   1 root root 9.9K Aug 27  2011 reelvdr.all
-rwxr-xr-x   1 root root  896 Aug 29  2015 remove-symlinks
-rwxr-xr-x   1 root root 2.5K Aug 12  2014 rpcbind
-rwxr-xr-x   1 root root 1.7K Jan  9  2010 rpcbind.dpkg-old
lrwxrwxrwx   1 root root   21 Jan  2  2015 rpc.pipefs -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 4.3K Apr 17  2014 rsync
lrwxrwxrwx   1 root root   21 Jan  2  2015 rsyslog -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 2.3K May  9  2014 saned
-rwxr-xr-x   1 root root 6.4K Aug 29  2015 sanitycheck-reel
-rwxr-xr-x   1 root root 3.0K Jan  4  2014 schroot
lrwxrwxrwx   1 root root   21 Jan  2  2015 screen-cleanup -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 3.9K Mar 13  2014 sendsigs
-rwxr-xr-x   1 root root 1.8K Feb 15  2010 sensord
-rwxr-xr-x   1 root root 2.8K Dec  8  2015 setAcpiWakeup
-rwxr-xr-x   1 root root 5.1K Oct 29  2012 setserial
-rwxr-xr-x   1 root root  762 Jan 29  2012 setup-shares
-rwxr-xr-x   1 root root 3.2K Jun 26  2012 set_wol
-rwxr-xr-x   1 root root 3.2K Jun 26  2012 set_wol.reel
-rwxr-xr-x   1 root root 3.2K Apr  1  2013 set_wol.vdr
-rwxr-xr-x   1 root root 4.7K Apr 11  2012 shellinabox.dpkg-dist
-rwxr-xr-x   1 root root 4.2K Jun  5  2011 shmnet
-rwxr-xr-x   1 root root  590 Mar 13  2014 single
-rwxr-xr-x   1 root root 3.0K Apr  8  2010 sipwitch
-rw-r--r--   1 root root 4.2K Mar 13  2014 skeleton
-rwxr-xr-x   1 root root 3.5K Mar  7  2010 smartmontools
-rwxr-xr-x   1 root root 3.5K Sep  5  2013 smartmontools.dpkg-dist
-rwxr-xr-x   1 root root 2.4K Jun  5  2011 smb_client
-rwxr-xr-x   1 root root 2.1K Feb 19  2014 speech-dispatcher
-rwxr-xr-x   1 root root 2.0K Apr 15  2010 speech-dispatcher.all
-rwxr-xr-x   1 root root 4.0K May  2  2014 ssh
-rwxr-xr-x   1 root root  519 Sep  7  2009 stop-bootlogd
-rwxr-xr-x   1 root root 1.1K Sep  7  2009 stop-bootlogd-single
-rwxr-xr-x   1 root root 2.5K Jun 11  2013 stunnel4
-rwxr-xr-x   1 root root  731 Feb  5  2014 sudo
-rwxr-xr-x   1 root root 1.8K Nov  7  2009 swapd
-rwxr-xr-x   1 root root 1.6K Jan 19  2010 sysstat
-rwxr-xr-x   1 root root 1.6K Jan 19  2010 sysstat.dpkg-new
-rwxr-xr-x   1 root root 250K Apr 14  2014 systemd-logind
-rwxr-xr-x   1 root root 4.3K Sep 10  2010 telnetd-reel
lrwxrwxrwx   1 root root   21 Jan  2  2015 tftpd-hpa -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 1.2K Feb 12  2014 thermald
-rwxr-xr-x   1 root root 1.8K May 26  2012 tntnet
-rwxr-xr-x   1 root root 6.0K Nov  9  2013 twonkyserver.all
-rwxr-xr-x   1 root root 1.8K Nov  8  2013 twonkywebdavserver.all
lrwxrwxrwx   1 root root   21 Jan  2  2015 ufw -> /lib/init/upstart-job
-rwxr-xr-x   1 root root 2.7K Mar 13  2014 umountfs
-rwxr-xr-x   1 root root 2.3K Mar 13  2014 umountnfs.sh
-rwxr-xr-x   1 root root 1.9K Mar 13  2014 umountroot
-rwxr-xr-x   1 root root 1.4K Dec  6  2013 unattended-upgrades
-rwxr-xr-x   1 root root 3.1K Mar 13  2014 urandom
-rwxr-xr-x   1 root root 3.2K Dec  8  2014 vdradmin
-rwxr-xr-x   1 root root 3.2K Dec  8  2014 vdradmin.all
-rwxr-xr-x   1 root root 2.4K Mar 23  2010 vdr-xxv.dpkg-new
-rwxr-xr-x   1 root root  999 Dec 26  2014 vncserver.all
-rwxr-xr-x   1 root root 2.3K Mar  7  2010 wpa-ifupdown
-rwxr-xr-x   1 root root 2.7K Sep 25  2013 x11-common
-rwxr-xr-x   1 root root 2.4K Oct 26  2013 xinetd.all
-rwxr-xr-x   1 root root 2.2K Mar  7  2010 xinetd.dpkg-old
-rwxr-xr-x   1 root root 2.5K Nov  9  2014 xxvd.all

Hope this helps.

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Ok, remove the currently installed version.

sudo apt-get remove --purge tvheadend*

then remove the old repository.

sudo apt-add-repository -r http://apt.tvheadend.org/unstable

then follow the guide on the AptRepository page to use the bintray repository. With any luck it should install correctly :).

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello and good morning Mark,

Purged and followed that guide at AptRepository.

Getting the same errors as before.

ps -ef but no tvheadend and finally

sudo service tvheadend start

[email protected]:/media/hd/home/reel$ sudo service tvheadend start
[sudo] password for reel:
tvheadend: unrecognised service

I went with the stable version :

<pre>
1. Add Bintray's GPG key:
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61 

# tvheadend - Stable branch - official releases
echo deb https://dl.bintray.com/tvheadend/ubuntu stable main | sudo tee -a /etc/apt/sources.list 
</pre>

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello again,

Entered those commands again , this time folloed the first post i made and it seems we have lift off. :)

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
sudo apt-get install curl
echo deb https://dl.bintray.com/tvheadend/ubuntu stable main | sudo tee -a /etc/apt/sources.list 
sudo apt-get update
sudo apt-get install tvheadend

Finally , got to see the username , password prompts and they went through.

Completely blanck of any tv/sat channels though.

Atleast i can see the web interface which is a good start.

Many thanks.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

Really appreciate your time.

Now that i can see the web interface , would it be possible to show me how to scan in 2 sat tuners plus one terrestrial tuner.

I can´t seem to do it.

On clicking on tv adapters i can see my 3 tuners but the configuration i just do not understand this , every detail seems to have to be done on manual.

Isn´t there an auto feature here , where tvheadend scans in all your tuners ?

Need help and thanks.

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

Really appreciate your time.

Now that i can see the web interface , would it be possible to show me how to scan in 2 sat tuners plus one terrestrial tuner.

I can´t seem to do it.

On clicking on tv adapters i can see my 3 tuners but the configuration i just do not understand this , every detail seems to have to be done on manual.

Isn´t there an auto feature here , where tvheadend scans in all your tuners ?

Need help and thanks.

You need to create a network, add your muxes and assign that network to your adaptors (don't forget to enable them). There is pre-defined muxes for many locations but they're usually out of date, but you can try one though. Do you know what satellite your dish is pointing at?

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

My apologies for not getting back to you a bit early.

Seems there is partial success on the terrestrial part and the channels scanned into Kodi too , but no signal..:(

Atleast they were scanned but once scanned went to open a channel and vlc opened and that was it. Disappointment there.

On the satellite front a have a discque 4 input , 1 output .

1 - 13 e
2 - 19.2 e
3 - 28.2 e

I not sure if you have to configure all the sats in one go or jut one at a time.

Anyhow, i enabled 13 e first in Tv adapters and added 13 e again under networks but nothing

RE: Sat>ip not connecting to tvheadend mistery - Added by Mark Clarkstone 7 months ago

Paul Brown wrote:

Hello Mark,

My apologies for not getting back to you a bit early.

Seems there is partial success on the terrestrial part and the channels scanned into Kodi too , but no signal..:(

Atleast they were scanned but once scanned went to open a channel and vlc opened and that was it. Disappointment there.

On the satellite front a have a discque 4 input , 1 output .

1 - 13 e
2 - 19.2 e
3 - 28.2 e

This might be in reverse order, try switching them around (in tvh) if the services don't match up with the positions.

I not sure if you have to configure all the sats in one go or jut one at a time.

One sat per network, assign network to tuner/position.

Don't forget to set the orbital position (very important).

Anyhow, i enabled 13 e first in Tv adapters and added 13 e again under networks but nothing.

The scanning can take up 5-10 mins to begin, this is so you can make changes if needed.

Click the bar at the bottom of the screen, attempt to play a service/channel & post the output here.

RE: Sat>ip not connecting to tvheadend mistery - Added by Paul Brown 7 months ago

Hello Mark,

I made a mess of the install i think , it must be me. Tdt channels were found and mapped into kodi but not the satellite ones.

The muxes were there but i went out and came back but the screen was the same , just muxes . :(

I thought may be get rid of the stable and bring on unstable or testing .

This is how i did that :

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
sudo apt-get install curl
echo deb https://dl.bintray.com/tvheadend/ubuntu testing main | sudo tee -a /etc/apt/sources.list 
sudo apt-get update
sudo apt-get install tvheadend

On entering < sudo apt-get install tvheadend > i get the below message :

[email protected]:/media/hd/home/reel$ sudo apt-get install tvheadend
[sudo] password for reel: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package tvheadend

I am confused now, so why this message , it dosen´t make any sense ?

Why is this made so difficult ?

Please help and thanks.

1 2 (1-25/46)