IPTV automatic network

Added by Bert Haverkamp 29 days ago

Hello all,

I just set up an IPTV network provider in Tvheadend (4.1-2398~gc38af4c~xenial)
It automatically imported 5000+ muxes.
I however dont want to have them all scanned. The provider will block the IP address when channel zapping to quickly.
Can I set them manually to active in one go?

Regards,

Bert


Replies (8)

RE: IPTV automatic network - Added by Bert Haverkamp 29 days ago

I guess the real question is how to map them to services en mass.:)

RE: IPTV automatic network - Added by Bert Haverkamp 29 days ago

Thx. I will try.
But the last reply is not very happy.

Regards,

Bert

RE: IPTV automatic network - Added by Bert Haverkamp 29 days ago

Hi,

I got a bit further now. I was able to add all 5079 services in one go.
And the channels are even visible in Kodi.
But in the background it was still scanning the channels. Got to about 300 in 5 hours. So with sufficient patience, it will get there (3.5 days... I did the math:-)
Then when I tried to watch one of the channels in Kodi, it locked up my provider. They have a strict limit on 1 channel per subscription and immediately block the IP address if you don't adhere.

This might even be a bug in tvheadend, because I specified that "Maximum # input streams:" equals 1.
However, when tuning a channel via kodi, it didn't wait to release the channel that was being tuned to for scanning.
Hence the blocking.

So 2 questions:
- How can I completely disable the scanning part.
- Can someone confirm that there is a bug in tvheadend with scanning and tuning going over the maximum # of input streams?

Good night

Bert

RE: IPTV automatic network - Added by Bert Haverkamp 29 days ago

Related question:
During the scaning tvheadend mentions in the log:
registering mux for OTA EPG
does this mean the scanning is triggerd by the EPG? Or is this just a side note of the initial or idle scanning?

Regards,

Bert

RE: IPTV automatic network - Added by C K 28 days ago

Disable EPG for all IPTV muxes

RE: IPTV automatic network - Added by John Rexter 26 days ago

Hi Bert, what happens if you try to watch a channel which has not been scanned yet? Does it work for you?

For me I can avoid the scanning by following the advice in https://tvheadend.org/issues/4144#change-20562
However, if I then try to watch a channel it does not work, I need to scan before the channel works. What I noticed is that the stream links generated before scanning are different from after scanning. Do you see the same thing?

Thanks

RE: IPTV automatic network - Added by Bert Haverkamp 23 days ago

Hi John, et. al.

I've started over again and the log seems quiet with scanning messages.
I used the advice from https://tvheadend.org/issues/4144#change-20562 and disabled 'Scan after creation'
I also set the Service ID to 1 (1 because that was the value the channels changed to after scanning in my previous attempts)
I also set the Network ID to 1, just to be sure.
However after creating all of the 5079 muxes, they have Network ID 65535 and Transport Stream ID 65535.
Also for all the muxes the EPG scan is set to "Enable (auto)" How can I set this to disable for all muxes at once?

@John, the muxes seem to get the right URL in the format:
http://clientportal.link:8080/live/username/password/15305.ts

But after kodi has started and imported all channels (which takes a while), when I start watching a channel,
I get the following error in the tvheadendlog subscription:
0048: No input source available for subscription "192.168.71.232 [ Kodi | Kodi Media Center ]" to channel "BBC One N West UK"
I verified the stream url and it plays fine in VLC.

(1-8/8)