Live TV is black screen except for ads?

Added by Jon Baumgartner 3 months ago

Hi, just got started with tvheadend and LibreELEC. I don't have the EPG working yet, but I'm just trying to watch live TV. Everything seems to be working as long as ads are airing, but as soon as the actual show starts, I get a black screen with no audio. Then as soon as an ad starts up, I get everything back!

I"m using an HDHomeRun with Verizon Fios. Is this some kind of crazy Verizon copy-protection scheme? These are not encrypted channels or anything.

Thanks!


Replies (14)

RE: Live TV is black screen except for ads? - Added by saen acro 3 months ago

Is your system support HDCP,
some Open Source drivers do not support it.
Give us more info about your hardware,
to minimize possible problems.

RE: Live TV is black screen except for ads? - Added by Jon Baumgartner 3 months ago

I'm not sure which hardware you need, but the PC is an Acer Revo RL70, and it is connected via HDMI.

https://www.newegg.com/Product/Product.aspx?Item=N82E16883103423

Previously, the Acer was displaying and recording live TV with Windows Media Center, if that helps.

RE: Live TV is black screen except for ads? - Added by Robert Cameron 3 months ago

There's a known bug with Intel display adapters, protected/HDCP streams and H.264 encoded video on Windows. I've only heard of it affecting people watching DRM-protected TV streams (via CableCARD) on WMC, but perhaps you've been caught up in it somehow?

RE: Live TV is black screen except for ads? - Added by Jon Baumgartner 3 months ago

Just so I'm clear, are you suggesting that WMC was somehow authorizing the protected content, but it wasn't supposed to? And Kodi is not able to do this?

RE: Live TV is black screen except for ads? - Added by Robert Cameron 3 months ago

Jon Baumgartner wrote:

Just so I'm clear, are you suggesting that WMC was somehow authorizing the protected content, but it wasn't supposed to? And Kodi is not able to do this?

There is a known bug with Intel graphics and HDCP streams that have H.264 (MPEG-4) encoded video. As far as I know it's limited to WMC, because for the most part that's the only software that implements HDCP. However, Verizon is known for marking some channels with copy protection flags that one would expect to be marked "copy freely". Without knowing any more information about your setup, everything is just a guess.

If you'd like additional help, you need to provide details. Even then, it sounds like an isolated bug/issue, so I'm not certain what can be done from our end.

RE: Live TV is black screen except for ads? - Added by saen acro 3 months ago

System of @Jon Baumgartner is With AMD graphic /AMD Radeon HD 6320/

WMC use PlayReady descrambling

RE: Live TV is black screen except for ads? - Added by Jon Baumgartner 3 months ago

Right not Intel. I'm happy to provide details but I'm not sure what details you need?

RE: Live TV is black screen except for ads? - Added by Robert Cameron 3 months ago

Jon Baumgartner wrote:

Right not Intel. I'm happy to provide details but I'm not sure what details you need?

It's likely some isolated bug you've found, but for starts, how about the particular hardware and software used?
We can assume Tvheadend, but which version? Linked against your system's ffmpeg, or its own? What are the hardware specs of the server? The Client?

Are you using the HTTP stream direct from the Prime, or are you transforming it in any way?

Right now, we know nothing.

RE: Live TV is black screen except for ads? - Added by saen acro 3 months ago

One more information, for channels with do not have picture.
Go to Configuration>DVB Inputs>Services
And make picture or just paste content of info page, (blue i) on some of problematic channels.

RE: Live TV is black screen except for ads? - Added by Robert Cameron 2 months ago

saen acro wrote:

One more information, for channels with do not have picture.
Go to Configuration>DVB Inputs>Services
And make picture or just paste content of info page, (blue i) on some of problematic channels.

That's not likely to help. If I understand the OP, he's using HDHR Primes as an IPTV source, not using the tvhdhomerun client built-in.

RE: Live TV is black screen except for ads? - Added by saen acro 2 months ago

And again less given information bring more questions.
Is in use is HDHR3-CC or other device?
That is why need to give all information not on small portion when ask.

RE: Live TV is black screen except for ads? - Added by Robert Cameron 2 months ago

saen acro wrote:

And again less given information bring more questions.
Is in use is HDHR3-CC or other device?
That is why need to give all information not on small portion when ask.

If the OP is truly using Verizon FiOS, then the only HDHR devices he could be using is either HDHR3-CC (Prime), or the TECH3-6CC (TECH6, which is essentially 2 Primes in the same enclosure). Those are the only 2 CableCARD devices that SD manufactures.

RE: Live TV is black screen except for ads? - Added by Jon Baumgartner 2 months ago

Hey guys, sorry for the delay. Thanks for the assistance!

It's actually an HDHR-US Dual. No CableCard. Maybe that's my problem? We have the lowest tier TV subscription possible, so it's just local channels and some cable access stuff. I wouldn't think local channels would be scrambled, but I could always be wrong.

I'm running LibreELEC (v8.0.2) on the Acer, which is serving as both client and server. The TV is hooked up directly to the Acer via HDMI. Coax feeds into the HDHR from a splitter.

Tvheadend version: Build: 4.2.2-32 ~ LibreELEC Tvh-addon v8.1.111 (2017-05-28T09:11:07+01:00)

Attached a screenshot of the Configuration>DVB Inputs>Services for one of the channels.

Lastly, I'm using the Tvheadend HTSP client as the PVR plugin. Not sure of the version, can't figure out how to get it from the Kodi web interface.

screenshot.png (125 KB)

RE: Live TV is black screen except for ads? - Added by Robert Cameron 2 months ago

Well, if the channels are Clear QAM, do they play fine outside of Kodi? Tryin VLC, and from the File menu tell it to open a network stream, using http://<HDHR IP>:5004/auto/v<ChannelNumber>. If it plays fine that way, it's a either a Tvheadend issue or a Kodi issue.

Following the same idea of using VLC, this time select a service or channel in the Tvheadend web UI, and paste the link from Tvheadend into VLC's "Open Network stream" dialog. If it plays fine there, hen the problem isn't Tvheadend, it's Kodi.

Another thing to check: make sure that Tvheadend is using the correct frequencies. It could be cable, or hrc, or irc. To see what your device says, from the command line, run hdhomerun_config <DeviceID> get /tuner0/channelmap. This will display which mapping your tuner is defaulting to. To see if the frequencies match, go to http://<HDHR IP>/lineup.html and select a channel to play. (If it doesn't open in VLC, copy the play link into VLC's "Open Network stream", as before) and let it play. Then in a command prompt, run hdhomerun_config <DeviceID> get /tuner0/channel and hdhomerun_config <DeviceID> get /tuner0/program. The channel and program should match the mux and service in Tvheadend. If they don't, then there's a problem with your Tvheadend configuration and you're using the wrong US cable frequencies.

Those options ought to get you going and be able to narrow down the problem.

(1-14/14)